Kickr dropouts using Bluetooth

Hi Team,

I am suffering multiple dropouts when connected to the app on Windows Laptop via Bluetooth from my Kickr. The laptop is about 30cm from my front wheel, so I wouldn’t have thought this would be the issue.

Cheers

Finn

1 Like

Hey Sir Finn, are you connecting your laptop to your wifi on the 2.4GHz or 5GHz connection? I found that swapping to 5GHz solved my bluetooth issues (mouse and keyboard dropouts included). This is because Bluetooth uses the 2.4GHz band, and signals can get congested.

2 Likes

Thanks Sir @chris.blom. I have forced laptop to 5ghz and will let you know how it goes.

2 Likes

I struggled the same issues, to have massive/multiple BT dropout during a workout.
One of the main reasons was my BT headphones I used. Lesson learned I removed as much BT devices from the pain cave as possible, just having my laptop and Kickr as active; every other devices is banned. And since then most of the time nothing dulls my suffering anymore ;)!

2 Likes

Yes, we often see Bluetooth headphones and speakers causing dropouts, even high powered fans can cause interference. I would suggest eliminating/turning off all other electronics in the room except the computer and Kickr. Then start gradually adding things back in to see if any one things causes the problem again.

1 Like

Any luck Sir @finndorney?

1 Like

I have it a quick go Sir @chris.blom, and it didn’t have a drop, but I don’t have another Suf ride until Tuesday now, so will let you know after that :wink:

3 Likes

Oh and if you’ve now turned off all fans as well, and it’s Nine Hammers on Tuesday … errr good luck

@chris.blom definitely better. I had a couple of dropouts but moving the laptop closer helped. I tried it with Zwift (ducking) with laptop in original position (just to check) and I didn’t experience any dropouts at all. So I’m guessing there is something here that could be worth looking at if others experience it. In reality, most of us need Bluetooth headphones because of the early morning workouts and sleeping kids, so I don’t want to have to resort to turning everything off of possible. @Sir_Martin, thankfully it wasn’t Nine Hammers, and I don’t have a Wahoo Headwind YET! :wink:

2 Likes

@chris.blom finally have a solution, or at least have worked out what the problem was. I was using a Garmin Tri HRM via Ant+ which I was trying to connect to Garmin Head Unit and SUF at the same time as I used to do with my Wattbike Atom. However, I realised that the Atom used to be able to take the connections and push it out to multiple devices with no issues. Given the Kickr doesn’t do this, I now have a Wahoo Tickr, and connect via BT to SUF and Ant+ to my Garmin Head Unit. No drops outs at all since. :slight_smile:

2 Likes

Nice one @finndorney

2 Likes